How to Install Internet Explorer in Linux for Idiots

“Why the hell would you want to install Internet Explorer in Linux?”, you ask? Am I stupid? No. Well, at least I don’t think I am. 🙂

Sometimes you HAVE to load certain websites in Internet Explorer because there are still a lot of website designers that don’t know what tInternet Explorer Iconhe hell they are doing or have been brainwashed by Microsoft in believing that there are no other browsers out there, even though every other browser out there surpasses Internet Explorer in every way, even IE7. Why that browser still exists is beyond me; it should have gone down with Netscape. Stupid Microsoft brainwashing.

Anyhow, the fact remains: IE is a parasite that we must live with and use at one point or another. 😮

IEs 4 Linux is a remarkable project that allows you to run Internet Explorer 6, 5.5, and 5 on Linux, all at the same time (optional).

“Kevin, would you shut up and tell me how I can quickly and easily install this in Ubuntu?” Well, to answer your question, I won’t shut up! And you can quickly and easily install this in Ubuntu by following these steps:

You have to enable universe packages first. It is also recommended that you use the official winehq ubuntu package:

1) Open a terminal

2) Open /etc/apt/sources.list
sudo gedit /etc/apt/sources.list
3) Uncomment (or add) following lines:

deb http://us.archive.ubuntu.com/ubuntu edgy universe

4) Add this line:

deb http://wine.budgetdedicated.com/apt edgy main

5) Close gedit. Update and install wine and cabextract:

wget -q http://wine.budgetdedicated.com/apt/387EE263.gpg -O- | sudo apt-key add -
sudo apt-get update
sudo apt-get install wine cabextract

PLEASE NOTE THAT LINES 00 AND 01 ABOVE ARE SUPPOSE TO BE ON ONE LINE!!! IT IS TOO LONG AND WRAPPING TO 2 LINES!

6) Download IEs 4 Linux and install

wget http://www.tatanka.com.br/ies4linux/downloads/ies4linux-latest.tar.gz
tar zxvf ies4linux-latest.tar.gz
cd ies4linux-*
./ies4linux

PLEASE NOTE THAT LINES 00 AND 01 ABOVE ARE SUPPOSE TO BE ON ONE LINE!!! IT IS TOO LONG AND WRAPPING TO 2 LINES!

Note for Dapper users: if you use Ubuntu Dapper, replace ‘edgy’ with ‘dapper’ on the lines above.

When I finished installing IE on my Ubuntu, I noticed an unhidden “ies4linux-2.0.5” directory. This folder simply contains installation files and scripts and can safely be removed.

With all the Internet Explorers installed and 3 new icons on my desktop (and not wanting them there), I created a new Drawer on my bottom panel, used the icon pictured above (taken from Deviantart) as the Drawer’s icon, dragged the 3 icons from my Desktop to the new Drawer, and deleted the icons from my Desktop.

Easy as pie! An idiot’s grandma can do it! 😛

BTW, did you subscribe to Linux FUD, yet? You should. It’s good for your health. 😉

Tags:

19 responses to “How to Install Internet Explorer in Linux for Idiots”

  1. Kevin Guertin says :

    @ Jonathan Wagener: IE’s user base is so huge because it is forced on users with its Operating System. It is not by choice. If it wasn’t included in Windows and the user had a choice, IE would be left crying in the dust. The majority of users are not computer savvy and have no idea that there are other browsers out there.

    @ linuxer: I have no idea what your comment has to do with this post.

  2. verman says :

    This does not work, it says

    .ies4linux/downloads/DCOM98.EXE: no valid cabinets found
    An error occured when trying to cabextract some files.

  3. shohag says :

    well, i like firefox the boss.🙂

  4. Kevin Guertin says :

    I agree. But when you work in web design and development, you need to be able to test in all the browsers.

  5. Net Nut says :

    IE updates.. ok, so I got it to run ie6 but there are some cumulitive ie updates that need to be installed.. and on the forground although it looks like they are installing I see a bunch of err:setupapi: xxxxx copy error 32 c:\\windows\\ .. etc in the background.

    How can I install these patches.. I am trying to run the IE6 siebel interface which needs these updates to be installed. (the only reason I need ie6 is for this)

  6. Jesse says :

    Hey man, I’m having an issue with Ubuntu file associations, and Google turned up this article:
    https://linuxfud.wordpress.com/2006/09/03/ubuntu-linux-file-associations/

    But every time I try to go to that page I end up on this article: “How to install Internet Explorer…”
    What’s up with that?

  7. Jeremy says :

    “Kevin Guertin (23:37:39) :

    Looks like you don’t have permission to write to that directory, hence then “Permission denied”. Do a “sudo chown -hR chadwick:chadwick /home/chadwick/ies4linux-2.0.5/” where chadwick is your username.”

    THANKYOU SO MUCH! WORKED PERFECTLY AFTER THAT!

  8. Netgunner says :

    Ran command just as you said got this error:

    netgunner@netgunner-laptop:~$ wget http://www.tatanka.com.br/ies4linux/downloads/ies4linux-latest.tar.gz
    Error parsing proxy URL http://:8080/: Invalid host name.
    netgunner@netgunner-laptop:~$

    Any ideas?

    • Doug says :

      some please take a screenshot of internet explorer on a linux desktop and, tell us how you did it, thanks

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: