Amarok Suddenly Stops Playing MP3s

I noticed today that Amarok suddenly decided to stop supporting MP3 playback. I would try to load a song in a playlist and Amarok would tell me something along the lines that it does not support the MP3 format and that Xine couldn’t play it. It provided me with a “Install MP3 Support” button, but I when I would click it Amarok would freeze and I’d have to kill it.

This perplexed me since it worked yesterday.

My first step was to see if I could play an MP3 from another application like Listen. It worked.

I tried re-installing Amarok, but that didn’t work. I did some Googling and found the solution:

  1. Close Amarok
  2. Delete the ~/.xine folder. (That’s the .xine folder in your Home directory)
  3. Restart Amarok.
  4. Play an MP3

Since this may have been a unique situation, this solution may not necessarily work for you. Nonetheless, I hope I helped someone out there. If it did work for you, please leave any comment here so I know I helped someone! 🙂

Tags:

37 responses to “Amarok Suddenly Stops Playing MP3s”

  1. m says :

    this didnt work for me. what else can ido?

  2. Le says :

    Thanks! Worked for me too.

  3. Les says :

    Thanks! Worked for me too.

  4. FPL says :

    Yes, I had the same problem, thanks.

    FPL

  5. dr4 says :

    worked for me thanks!

  6. orhan says :

    yes it did worked for me too🙂
    many thanks

  7. Chris says :

    Can’t thank you enough! Cheers

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: